History log of /imagick/imagick.c (Results 126 – 150 of 474)
Revision (<<< Hide revision tags) (Show revision tags >>>) Date Author Comments
# 8221be44 09-May-2014 Danack

Correctly release memory for a single shutdown function.


# 130286a5 09-May-2014 Danack

Surprisingly, first working version of a callable progress monitor.


# 410e2cf1 24-Mar-2014 Danack

Added version check to compare version that Imagick was compiled against, with the version of Image Magick that has been loaded.


# 076a284c 30-Dec-2013 Mikko

Remove zend MM stuff


# 5c54a21d 26-Dec-2013 Mikko

Exclude deprecated methods


# 86671bd0 03-Dec-2013 Mikko

MagickGetImageCompression


# 15ee06d0 26-Nov-2013 Mikko

Windows again


# 807a1283 26-Nov-2013 Mikko

Windows <3


Revision tags: 3.2.0RC1
# 97857130 18-Nov-2013 Mikko

Only install headers as needed


# 5c241fe6 14-Nov-2013 Mikko

Fixed PHP Bug 66098: Segfault in zval_addref_p


Revision tags: 3.2.0b2
# 872f6f03 19-Oct-2013 Mikko

Added ImagickPixel::isPixelSimilar and deprecate ImagickPixel::isSimilar #10


# 1eb97f63 17-Oct-2013 Mikko

Added imagick::smushimages


# cb83c235 17-Oct-2013 Mikko

added imagick::blueshiftimage and imagick::clampimage


# e959bbe4 17-Oct-2013 Mikko

Added Imagick::autolevelimage


# dfc1c519 13-Oct-2013 Mikko

More tests with zend mm


# 580c0376 06-Oct-2013 Mikko

Remove whitespace


# 596d433f 06-Oct-2013 Mikko

Init keep alive to null, add braces in case of multiline macro impl


Revision tags: 3.2.0b1
# 3b1bb304 05-Oct-2013 Mikko

Error checking on allocs, alloc failure is a hard error


# 4bb2e4f1 04-Oct-2013 Mikko

Added somewhat experimental support for zend MM. Effectively allows Imagick to respect PHP memory limits


# 64184f41 03-Oct-2013 Mikko

Add optional format parameter for writeImageFile


# b939c105 01-Oct-2013 Mikko

Added support for countable in Imagick class


# f3f9828a 01-Oct-2013 Mikko

Remove duplicated code, correct typing, indentation


# 6617baf3 01-Oct-2013 Mikko

Rewrite PixelIterator related classes. Add getPixelIterator and getPixelRegionIterator static methods. Should probably add Countable interface later


# 04568bbf 30-Sep-2013 Mikko

More consistent naming on the colors. Make the colors a type instead of free-floating constants. Function naming consistency


# 4fa76f81 30-Sep-2013 Mikko

Make the macro name more explicit. Remove unnecessary cast


12345678910>>...19